From aa88ea846750f62f03c93c5834738d747fc32020 Mon Sep 17 00:00:00 2001 From: Roman Laptev Date: Wed, 2 Sep 2026 15:52:02 +0300 Subject: [PATCH 1/2] fix: support build 5 and package_config 3 Widen flutter_gen_runner dependency constraints to allow build 5.x and package_config 3.x, and document the compatibility update. Validated with build 5.0.0, package_config 3.0.0, and build_runner 2.17.1: all 3 workspace integration tests and 89 core tests pass; static analysis reports no issues. --- CHANGELOG.md | 6 ++++++ packages/runner/pubspec.yaml | 4 ++-- 2 files changed, 8 insertions(+), 2 deletions(-) diff --git a/CHANGELOG.md b/CHANGELOG.md index 351edeac..be3fb2ae 100644 --- a/CHANGELOG.md +++ b/CHANGELOG.md @@ -1,3 +1,9 @@ +## Unreleased + +**Development** + +- Allow `build` 5.x and `package_config` 3.x in `flutter_gen_runner` while retaining support for `build` 4.x and `package_config` 2.2.x. + ## 5.15.0 **Feature** diff --git a/packages/runner/pubspec.yaml b/packages/runner/pubspec.yaml index 208fae23..18abbcb5 100644 --- a/packages/runner/pubspec.yaml +++ b/packages/runner/pubspec.yaml @@ -11,12 +11,12 @@ environment: dependencies: flutter_gen_core: 5.15.0 - build: ^4.0.0 + build: '>=4.0.0 <6.0.0' build_config: ^1.1.2 collection: ^1.17.0 crypto: ^3.0.0 glob: ^2.0.0 - package_config: ^2.1.0 + package_config: '>=2.2.0 <4.0.0' path: ^1.8.0 yaml: ^3.0.0 From 3997d73922513bfdc938a85095a599d086bb5e71 Mon Sep 17 00:00:00 2001 From: Alex Li Date: Tue, 3 Nov 2026 10:59:40 +0800 Subject: [PATCH 2/2] Update CHANGELOG for build and package_config support Updated changelog to include support for new versions of build and package_config. --- CHANGELOG.md | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/CHANGELOG.md b/CHANGELOG.md index be3fb2ae..9c18dec8 100644 --- a/CHANGELOG.md +++ b/CHANGELOG.md @@ -2,7 +2,7 @@ **Development** -- Allow `build` 5.x and `package_config` 3.x in `flutter_gen_runner` while retaining support for `build` 4.x and `package_config` 2.2.x. +- [#784](https://github.com/FlutterGen/flutter_gen/pull/784) Allow `build` 5.x and `package_config` 3.x in `flutter_gen_runner` while retaining support for `build` 4.x and `package_config` 2.2.x. by [@Carapacik](https://github.com/Carapacik) ## 5.15.0