diff --git a/applications/anatomy.rst b/applications/anatomy.rst index 9373d1a..ba5185a 100644 --- a/applications/anatomy.rst +++ b/applications/anatomy.rst @@ -202,7 +202,7 @@ logical server—which is called a *service*\ —where a *load balancer* intercepts the request message and forwards it to one of a scalable number of backend processes. -It’s an implementation detail, but rather than a process, per se, each +It’s an implementation detail, but rather than a process, per :spelling:ignore:`se`, each instance is often a container, which is essentially a process encapsulated inside a self-contained environment that includes all the software packages the process needs to run. Docker is today’s diff --git a/capacity/aqm.rst b/capacity/aqm.rst index 45bbc96..cf508ef 100644 --- a/capacity/aqm.rst +++ b/capacity/aqm.rst @@ -406,7 +406,7 @@ commonly experience bufferbloat. `__. RFC 8289, January 2018. - T. Hoeiland-Joergensen, P. McKenney, D. Taht, J. Gettys, and E. Dumaze. + T. Hoeiland-Joergensen, P. McKenney, D. Taht, J. Gettys, and E. Dumazet. `The Flow Queue CoDel Packet Scheduler and Active Queue Management Algorithm `__. RFC 8290, January 2018. diff --git a/dict.txt b/dict.txt index 538559c..ad881f8 100644 --- a/dict.txt +++ b/dict.txt @@ -47,6 +47,7 @@ AlertManager ALF algorithmically Alizadeh +Allman allocators Ameen AMF @@ -103,6 +104,7 @@ attractor AUC audioconference audioconferencing +Auguste AUSF AUTH AuthenticationData @@ -114,6 +116,7 @@ AvgLen AVP aways AWS +Azimov backend backends backhaul @@ -148,16 +151,19 @@ benchmarked benchmarking BER Berfelde +Berners bessd BFD BGP BGP's BIDIR BigSwitch +Birrell BISYNC bitrate BitsPerPacket bitwise +Bjorklund blockchain Blockchain Blockchains @@ -170,6 +176,7 @@ BNGs Bohe Boggs BOM +Bonica boolean Booleans BOOTP @@ -207,6 +214,7 @@ CAs Casado Cascone Casetti +Casner CBRS CCN CCR @@ -229,12 +237,14 @@ checksummed checksumming checksums Cheng +Cheriton chipset chipsets Chiu Choi Christy chrominance +Chu cicd CIDR cidreg @@ -292,6 +302,7 @@ CRC CRCs CRL CRLF +Crocker crowdsource cryptanalysis cryptanalyst @@ -331,6 +342,7 @@ dataset datasets datatypes Davie +Davin DCCP DCE DCOM @@ -348,6 +360,7 @@ decapsulation decbit DECbit DECNET +decodable decrementing decrypt decrypted @@ -370,6 +383,7 @@ DES's dest DestinationAddr deterministically +dev devops DevOps dgram @@ -386,6 +400,8 @@ Diffserv DiffServ Diginomica dimensionality +Dimitropoulos +Dincer directionality disaggregate disaggregated @@ -403,8 +419,10 @@ DNS Dockerfile DockerHub DoCoMo +Doering dogfooding DoH +DOI Donenfeld DoQ DoS @@ -427,6 +445,8 @@ DstAddr DstIPAddr DstPort DT +Dumazet +Durand durations DUs dutt @@ -451,6 +471,7 @@ edgecloud EdgeCloud Edmar EffectiveWindow +Eggert EGP EKS ElasticSearch @@ -500,6 +521,7 @@ extensibility Fack facto failover +Fairhurst fait Farber's FARs @@ -512,6 +534,7 @@ FDM Feamster FEC FECs +Fedor femto FFT fgets @@ -592,6 +615,7 @@ Gnutella gNXI Goalposting GOAWAY +Goel GoLang Goldsworthy goodput @@ -649,6 +673,7 @@ HLS HMAC HMACs hoc +Hoeiland HopLimit hostname HotNets @@ -663,6 +688,7 @@ http HTTP's HTTPS Huawei +Huitema HungWei HW hyperparameter @@ -748,6 +774,7 @@ IOV ip IP IP's +ipad IPAM IPFIX ipfwdtab @@ -784,6 +811,7 @@ Janey Javascript Jiang jitter +Joergensen jpeg json judgement @@ -804,6 +832,7 @@ keepalive keepalives Kerberos Kerberos's +Kerckhoffs Keycloak Khosravi Kibana @@ -886,6 +915,7 @@ LSRs LTE LTE's luminance +Lychev Lyft LZ MacAddr @@ -896,11 +926,13 @@ MacOS macroblock macroblocks MACs +Mahajan mahalingam Mahdavi mailto Makefile MakeReservation +Mankin mapBind mapCreate mapResolve @@ -910,6 +942,7 @@ Markovian Mascolo marshaller marshalling +Masinter Mastership mathsf Matteo @@ -934,6 +967,7 @@ mckusick McKusick MeasurementLab megascale +Menezes MEP MEPs mergeRoute @@ -977,6 +1011,7 @@ MNO MNO's MNOs Mobicom +Mockapetris modelling modularity modularize @@ -1021,6 +1056,7 @@ multipath multiplicatively multipoint Multiprotocol +multivendor multiword mutator mux @@ -1157,7 +1193,9 @@ ONS ONU ONUs Ookla +Oorschot OPA +opad OpenAPI openconfig OpenConfig @@ -1236,6 +1274,7 @@ PDRs PDU pelr Pennarun +Pepelnjak performant Perlman perror @@ -1276,6 +1315,7 @@ Porkbun Postel postfix PostScript +Poutievski PPP PPP's PPPoE @@ -1298,6 +1338,7 @@ Predistribution preimage prem prepended +prepending preprocessing priori probabilistically @@ -1396,6 +1437,7 @@ repurposing requirements REs resends +Resnick resolvers REST's RESTCONF @@ -1456,6 +1498,7 @@ RSA RSA's RSpec RSVP's +rsync RTCP RTP RTS @@ -1488,11 +1531,15 @@ ScaleBricks Scandolo scapy SCCP +Schapira sched schedulable scheduleable scheduler's schemas +Schneier +Schoffstall +Schulzrinne scikit Scotty SCTP @@ -1543,7 +1590,9 @@ Shamir Shapira shenker Shenker's +Shoch shortcomings +Shreedhar Shroeder's Shuberg Sigcomm @@ -1554,6 +1603,7 @@ signalling SIGOPS siloed SIMs +Singhvi sinked sizeof SLAs @@ -1644,6 +1694,7 @@ Subnetting subnetwork subnetworks suboptimal +subprefix subproblems Subramaniam subrange @@ -1654,6 +1705,7 @@ subsampling Subsampling subsequently Substack +subtables subtrees subtype subtypes @@ -1687,6 +1739,7 @@ syscall syslog Syslog SystemsApproachLogoURL +Taht Tailscale talkspurt talkspurts @@ -1711,6 +1764,7 @@ templating TempP Tennenhouse Terraform +Testart testbed TestON TestVectors @@ -1720,6 +1774,7 @@ TGS th Thakur throughputs +Thurlow Tiago TimeBetweenPackets timeframe @@ -1857,7 +1912,9 @@ UUIDs UX Vachuska Vahdat +validator Vanderlinden +Vanstone Varghese varint varints @@ -1891,6 +1948,7 @@ VIDs Vik Villanova Vimeo +Vint virtualenv virtualization virtualization's @@ -1932,6 +1990,7 @@ VTN vxlan VXLANs waisted +Waitzman WANs Warcraft waveforms @@ -1953,6 +2012,7 @@ wifiExposedNode wifiHiddenNode Wijesinha wildcarded +Wilensky WindowSize wirelessBaseStation wirelessBluetoothPiconet @@ -1996,7 +2056,9 @@ Yukio YUV Zack Zegura +Zeilenga Zhang +Zhu ZigBee Zipf Ziv diff --git a/message/quic.rst b/message/quic.rst index 7858e98..5b0946e 100644 --- a/message/quic.rst +++ b/message/quic.rst @@ -316,9 +316,10 @@ packet has failed to arrive. A second source of noise in RTT estimation is the use of delayed ACKs, where a recipient waits some time before sending the ACK in response to a received packet. To remove this uncertainty, QUIC includes an ``ACK -Delay`` in the ACK frame indicates how -much time elapsed between the receipt of the data being ACK'ed and the -ACK being transmitted. +Delay`` in the ACK frame that indicates the acknowledgment delay intentionally +introduced by the receiver between receiving the largest acknowledged +packet (that is, the acknowledged packet with the largest packet number) and +transmitting the ACK. The ACK frame in QUIC builds on the idea of SACK (selective acknowledgments). A single diff --git a/message/rdma.rst b/message/rdma.rst index 02afd40..8ff6309 100644 --- a/message/rdma.rst +++ b/message/rdma.rst @@ -148,7 +148,7 @@ abstraction, but to understand how RDMA is used in practice, it is helpful to redraw it with the additional detail shown in :numref:`Figure %s `. Here, we see the application loads two libraries: ``libibverbs`` and ``librdmacm``. The -first—which you can read as "lib-ib-verbs", with the "ib" standing for +first—which you can read as ":spelling:ignore:`lib-ib-verbs`", with the ":spelling:ignore:`ib`" standing for InfiniBand—is effectively a low-level interface to an RDMA-capable device. Note that ``libibverbs`` directly interacts with the NIC, bypassing the OS. The OS still polices access to the NIC, but is not @@ -162,7 +162,7 @@ on the data path once access is granted to a particular application. Software components that implement RDMA, including user-level libraries that directly interact with the HCA (InfiniBand NIC). -The second library—which you can read as "lib-rdma-cm", with the "cm" +The second library—which you can read as ":spelling:ignore:`lib-rdma-cm`", with the "cm" standing for "Communication Manager"—defines optional wrapper functions that make the Verbs API easier to use. This second library could have instead been one of the libraries shown in :numref:`Figure @@ -261,7 +261,7 @@ Communication Management phase.) The third operation, data for the write.\ [#]_ Finally, the ``ibv_wr_complete`` operation signals to the NIC that the message is ready to be sent. -.. [#] The "sge" in ``ibv_wr_set_sge`` operation denotes the concept +.. [#] The ":spelling:ignore:`sge`" in ``ibv_wr_set_sge`` operation denotes the concept of "Scatter-Gather", indicating that the message to be written might be scattered across multiple non-continuous memory buffers. (Our particular "Hello World" message is located in a diff --git a/naming/dns.rst b/naming/dns.rst index d62ed5e..b63af30 100644 --- a/naming/dns.rst +++ b/naming/dns.rst @@ -362,7 +362,7 @@ introduce other defenses, in a companion book. `__. RFC 8484, October 2018. - C. Huitama, S. Dickinson and A. Mankin. `DNS Over Dedicated QUIC + C. Huitema, S. Dickinson and A. Mankin. `DNS Over Dedicated QUIC Connections (DoQ) `__. RFC 9250, May 2022. diff --git a/part_three.rst b/part_three.rst index ed53bcd..d3d4ecd 100644 --- a/part_three.rst +++ b/part_three.rst @@ -8,7 +8,7 @@ The edge devices connected to a network like the Internet—whether they are servers, laptops, mobile phones, or other consumer appliances—are -not managed as part of the network, per se, but they do play a +not managed as part of the network, per :spelling:ignore:`se`, but they do play a critical role in realizing a global network like today’s Internet. The edge is where applications run, along with a networking software stack that interacts with (connects the device to) the switches running diff --git a/secure/blocks.rst b/secure/blocks.rst index 264ea06..8e989c4 100644 --- a/secure/blocks.rst +++ b/secure/blocks.rst @@ -248,7 +248,7 @@ replace DES with newer algorithms. 3DES is now deprecated in favor of the *Advanced Encryption Standard* (AES) issued by NIST. The cipher underlying AES (with a few minor modifications) was originally named Rijndael (pronounced roughly -like “Rhine dahl”) based on the names of its inventors, Daemen and +like “Rhine :spelling:ignore:`dahl`”) based on the names of its inventors, Daemen and Rijmen. AES supports key lengths of 128, 192, or 256 bits, and the block length is 128 bits. AES permits fast implementations in both software and hardware, being somewhat more efficient than triple