Skip to content
Navigation Menu
Sign in
Appearance settings
Platform
AI CODE CREATION
GitHub Copilot
Write better code with AI
GitHub Copilot app
Direct agents from issue to merge
MCP Registry
Integrate external tools
DEVELOPER WORKFLOWS
Actions
Automate any workflow
Codespaces
Instant dev environments
Issues
Plan and track work
Code Review
Manage code changes
Code Quality
Enforce quality at merge
APPLICATION SECURITY
GitHub Advanced Security
Find and fix vulnerabilities
Code security
Secure your code as you build
Secret protection
Stop leaks before they start
EXPLORE
Why GitHub
Documentation
Blog
Changelog
Marketplace
View all features
Solutions
BY COMPANY SIZE
Enterprises
Small and medium teams
Startups
Nonprofits
BY USE CASE
App Modernization
DevSecOps
DevOps
CI/CD
View all use cases
BY INDUSTRY
Healthcare
Financial services
Manufacturing
Government
View all industries
View all solutions
Resources
EXPLORE BY TOPIC
AI
Software Development
DevOps
Security
View all topics
EXPLORE BY TYPE
Customer stories
Events & webinars
Ebooks & reports
Business insights
GitHub Skills
SUPPORT & SERVICES
Documentation
Customer support
Community forum
Trust center
Partners
View all resources
Open Source
COMMUNITY
GitHub Sponsors
Fund open source developers
PROGRAMS
Security Lab
Maintainer Community
GitHub Stars
Archive Program
REPOSITORIES
Topics
Trending
Collections
Enterprise
ENTERPRISE SOLUTIONS
Enterprise platform
AI-powered developer platform
AVAILABLE ADD-ONS
GitHub Advanced Security
Enterprise-grade security features
Copilot for Business
Enterprise-grade AI features
Premium Support
Enterprise-grade 24/7 support
Pricing
Search
/
Sign in
Sign up
Appearance settings
You signed in with another tab or window.
Reload
to refresh your session.
You signed out in another tab or window.
Reload
to refresh your session.
You switched accounts on another tab or window.
Reload
to refresh your session.
Dismiss alert
{{ message }}
openclaw
/
rfcs
Public
Notifications
You must be signed in to change notification settings
Fork
22
Star
9
Code
Issues
1
Pull requests
36
Actions
Projects
Security and quality
0
Insights
Additional navigation options
Code
Issues
Pull requests
Actions
Projects
Security and quality
Insights
All pull requests
New pull request
Search pull requests
is
:
pr
state
:
open
is:pr state:open
Clear filter
Search
Pull requests
Open
36
(36)
Closed
39
(39)
Author
Label
Projects
Milestones
Reviews
Assignee
Sort by
Newest
descending
More items
Comfortable display density
Compact display density
docs(rfc): propose Cloud Run Hosting and Cloud Run Sandboxes
merge-risk: 🚨 availability
merge-risk: 🚨 compatibility
merge-risk: 🚨 security-boundary
P2
rating: 🦐 gold shrimp
status: 📣 needs proof
#76
·
ryanpei
opened
Sep 28, 2026
·
·
12
docs(rfc): propose external-supervisor operator guidance
P3
rating: 🦪 silver shellfish
status: 📣 needs proof
#75
·
paulcam206
opened
Sep 22, 2026
·
·
6
docs: propose guest foreground work and restart notices
P3
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#74
·
vincentkoc
opened
Sep 22, 2026
Member
·
·
4
docs: propose host-owned process execution authorization
P2
rating: 🦐 gold shrimp
status: 📣 needs proof
#73
·
beenhero
opened
Sep 15, 2026
·
·
2
docs: make PR descriptions plain-language first
P3
proof: sufficient
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#72
·
roboclaw-bot
opened
Sep 12, 2026
·
·
2
docs: propose persistent Agent runtime lifecycle
P3
proof: 📸 screenshot
proof: sufficient
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#71
·
freeqaz-openai
opened
Sep 8, 2026
·
·
2
docs: propose service-owned work authority
P3
proof: 📸 screenshot
proof: sufficient
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#70
·
freeqaz-openai
opened
Sep 8, 2026
·
·
2
docs: propose workload identity and bounded enforcement
P3
proof: 📸 screenshot
proof: sufficient
rating: 🦞 diamond lobster
status: 👀 ready for maintainer look
#69
·
freeqaz-openai
opened
Sep 8, 2026
·
·
2
docs: propose credential lifecycle and GitHub App access
P3
proof: 📸 screenshot
proof: sufficient
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#68
·
freeqaz-openai
opened
Sep 8, 2026
·
·
2
docs: propose a community visual identity and typography direction
P3
proof: 📸 screenshot
proof: sufficient
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#67
·
sergiopesch
opened
Sep 8, 2026
·
·
2
docs: propose plugin update availability
P3
rating: 🦐 gold shrimp
status: 📣 needs proof
#66
·
ekinnee
opened
Sep 6, 2026
·
·
2
docs: propose demand-driven session sidebar collections
feature: ✨ showcase
P3
rating: 🦪 silver shellfish
status: 📣 needs proof
#64
·
clawsweeper
opened
Aug 23, 2026
·
·
2
RFC 0030: Claws Eve portability profile
merge-risk: 🚨 compatibility
merge-risk: 🚨 security-boundary
P3
rating: 🦐 gold shrimp
status: 👀 ready for maintainer look
#63
·
giodl73-repo
opened
Aug 21, 2026
Contributor
·
·
2
RFC 0029: clarify Control Model capability and additive scope
P3
proof: sufficient
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#62
·
giodl73-repo
opened
Aug 21, 2026
Contributor
·
·
8
docs: propose gateway containment via Windows Isolation Sessions
merge-risk: 🚨 security-boundary
P3
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#61
·
paulcam206
opened
Aug 18, 2026
·
·
5
docs: propose Claw composition evidence RFC
merge-risk: 🚨 compatibility
merge-risk: 🚨 security-boundary
P3
rating: 🦐 gold shrimp
status: ⏳ waiting on author
#60
·
momothemage
opened
Aug 5, 2026
·
·
1
RFC 0029: External Automation Deadlines and Schedule-Only Occurrences
P3
rating: 🦪 silver shellfish
status: 📣 needs proof
#59
·
omarshahine
opened
Aug 4, 2026
Contributor
·
·
1
docs: propose OpenClaw MSIX packaging for Windows
merge-risk: 🚨 compatibility
merge-risk: 🚨 security-boundary
P3
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#58
·
xlinush
opened
Aug 4, 2026
·
·
11
RFC 0020: OpenShell Worker Provider and Credential-Brokered Session Sandboxes
merge-risk: 🚨 compatibility
merge-risk: 🚨 security-boundary
P3
rating: 🦐 gold shrimp
status: ⏳ waiting on author
#55
·
sallyom
opened
Jul 31, 2026
·
·
1
docs: propose OpenClaw-owned Rust node runtime
feature: ✨ showcase
P3
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#54
·
giodl73-repo
opened
Jul 29, 2026
Contributor
·
·
39
RFC 0027: Simplified Technical English for OpenClaw documentation
P3
rating: 🦪 silver shellfish
status: 📣 needs proof
#53
·
jjjhenriksen
opened
Jul 29, 2026
·
·
2
docs(localization): clarify progressive slice delivery
merge-risk: 🚨 security-boundary
P2
rating: 🦐 gold shrimp
status: ⏳ waiting on author
#49
·
giodl73-repo
opened
Jul 24, 2026
Contributor
·
·
23
RFC 0016: consolidate the Claws contract
merge-risk: 🚨 compatibility
merge-risk: 🚨 security-boundary
P2
rating: 🐚 platinum hermit
status: 📣 needs proof
#48
·
giodl73-repo
opened
Jul 22, 2026
Contributor
·
·
19
RFC 0013 addendum: application-consistent recovery for scale-to-zero
feature: ✨ showcase
P2
rating: 🦐 gold shrimp
status: 📣 needs proof
#46
·
giodl73-repo
opened
Jul 21, 2026
Contributor
·
·
8
RFC 0023: Standard Hosting Profiles
feature: ✨ showcase
P3
proof: sufficient
rating: 🐚 platinum hermit
status: 👀 ready for maintainer look
#37
·
giodl73-repo
opened
Jul 14, 2026
Contributor
·
·
10
Previous
1
2
Next
You can’t perform that action at this time.