Repository navigation
Update Mise tool dependencies - #115
renovate[bot] wants to merge 1 commit into
Conversation
|
Renovate Jira issue ID: BUILD-12433 |
1c6615e to
70ac82a
Compare
70ac82a to
93b1548
Compare
93b1548 to
6b58a89
Compare
6b58a89 to
4a1743c
Compare
4a1743c to
82ddf65
Compare
Code Review 👍 Approved with suggestions 0 closed / 1 findings🟡 Medium risk · Updating the configured Python and Poetry tool versions could change dependency resolution or compatibility, affecting local development and CI behavior. Bumps Poetry from 1.8.4 to 1.8.5 and Python from 3.13.7 to 3.15.1 in the mise toolchain. Approved with a suggestion: Poetry 1.8.5 does not list Python 3.15 support, so consider keeping Python on 3.13.x or upgrading Poetry to 2.5 or later alongside the interpreter ( 💡 Edge Case: Python 3.15.1 paired with Poetry 1.8.5, which isn't supported on 3.15This PR moves Python from 3.13.7 to 3.15.1, two minor versions at once, but leaves Poetry on the 1.8.x line. Poetry 1.8.5 lists classifiers only up to Python 3.13 and pins Stay on a Python version Poetry 1.8.x supports🤖 Prompt for agentsVerification Rules 2/2 metFunctional validation No results Rules 2 passed 1 not applicable
Auto-approval Not enabledFor more verification details, comment OptionsAuto-apply is off → Gitar will not commit updates to this branch. Comment with these commands to change the behavior for this request:
Was this helpful? React with 👍 / 👎 | Gitar |
|
| poetry = "1.8.5" | ||
| python = "3.15.1" |
There was a problem hiding this comment.
💡 Edge Case: Python 3.15.1 paired with Poetry 1.8.5, which isn't supported on 3.15
This PR moves Python from 3.13.7 to 3.15.1, two minor versions at once, but leaves Poetry on the 1.8.x line. Poetry 1.8.5 lists classifiers only up to Python 3.13 and pins poetry-core==1.9.1 (PyPI metadata). Poetry's release history shows official support for Python 3.14 arriving in 2.2.0 and for Python 3.15 in 2.5.0 (2.5.0 announcement). After this change, the mise toolchain used locally and by the build-poetry CI action pairs an interpreter with a Poetry release that was never tested on it. I didn't find a specific runtime failure for 1.8.5 on 3.15, so the risk is that this combination is unsupported, not that it is known to break. Either keep Python on a version Poetry 1.8 supports (3.13.x), or upgrade Poetry to >=2.5 along with the interpreter.
Stay on a Python version Poetry 1.8.x supports:
[tools]
poetry = "1.8.5"
python = "3.13.7"
- Apply fix
Check the box to apply the fix or reply for a change | Was this helpful? React with 👍 / 👎



This PR contains the following updates:
1.8.4→1.8.53.13.7→3.15.13.15.2Release Notes
python-poetry/poetry (poetry)
v1.8.5Compare Source
Changed
pkginfo>=1.12to fix an issue with an unknown metadata version 2.4 (#9888).python/cpython (python)
v3.15.1Compare Source
v3.15.0Compare Source
v3.14.10Compare Source
v3.14.9Compare Source
v3.14.8Compare Source
v3.14.7Compare Source
v3.14.6Compare Source
v3.14.5Compare Source
v3.14.4Compare Source
v3.14.3Compare Source
v3.14.2Compare Source
v3.14.1Compare Source
v3.14.0Compare Source
v3.13.18Compare Source
v3.13.17Compare Source
v3.13.16Compare Source
v3.13.15Compare Source
v3.13.14Compare Source
v3.13.13Compare Source
v3.13.12Compare Source
v3.13.11Compare Source
v3.13.10Compare Source
v3.13.9Compare Source
v3.13.8Compare Source
Configuration
📅 Schedule: (in timezone CET)
🚦 Automerge: Disabled by config. Please merge this manually once you are satisfied.
♻ Rebasing: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.
👻 Immortal: This PR will be recreated if closed unmerged. Get config help if that's undesired.
This PR was generated by Mend Renovate. View the repository job log.