Repository navigation
Add this suggestion to a batch that can be applied as a single commit.
This suggestion is invalid because no changes were made to the code.
Suggestions cannot be applied while the pull request is closed.
Suggestions cannot be applied while viewing a subset of changes.
Only one suggestion per line can be applied in a batch.
Add this suggestion to a batch that can be applied as a single commit.
Applying suggestions on deleted lines is not supported.
You must change the existing code in this line in order to create a valid suggestion.
Outdated suggestions cannot be applied.
This suggestion has been applied or marked resolved.
Suggestions cannot be applied from pending reviews.
Suggestions cannot be applied on multi-line comments.
Suggestions cannot be applied while the pull request is queued to merge.
Suggestion cannot be applied right now. Please check back later.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
💡 Edge Case: Python 3.15.1 paired with Poetry 1.8.5, which isn't supported on 3.15
This PR moves Python from 3.13.7 to 3.15.1, two minor versions at once, but leaves Poetry on the 1.8.x line. Poetry 1.8.5 lists classifiers only up to Python 3.13 and pins
poetry-core==1.9.1(PyPI metadata). Poetry's release history shows official support for Python 3.14 arriving in 2.2.0 and for Python 3.15 in 2.5.0 (2.5.0 announcement). After this change, the mise toolchain used locally and by thebuild-poetryCI action pairs an interpreter with a Poetry release that was never tested on it. I didn't find a specific runtime failure for 1.8.5 on 3.15, so the risk is that this combination is unsupported, not that it is known to break. Either keep Python on a version Poetry 1.8 supports (3.13.x), or upgrade Poetry to >=2.5 along with the interpreter.Stay on a Python version Poetry 1.8.x supports:
Check the box to apply the fix or reply for a change | Was this helpful? React with 👍 / 👎